General slowness when using Basecone

Incident Report for Basecone

Resolved

This incident has been resolved.
Posted Aug 05, 2024 - 16:16 CEST

Investigating

You can experiencing performance issues when trying to upload, make a booking or browsing through documents. We are looking into the problems at this moment.
Posted Aug 05, 2024 - 15:21 CEST
This incident affected: WebPortal.